Jump to content

Recommended Posts

Hey everyone,

 

With the change to Battleye, a few users have poked me with issues getting their games running, so I figured I would create a thread for you all with common problems and solutions. This post will be updated as more common issues come my way, but for now I highly recommend anyone with an issue check out this FAQ for Battleye. It has a lot of useful information and has helped most users resolve their problems so far.

 

Some common issues:

 

  • If you have custom configurations or are using the advanced launcher and are having problems, try starting from a clean install of the game and then add things on bit by bit to find the problematic elements.
  • As many community members have pointed out, Reshade is not supported by Battleye. Please be sure to disable it before running APB
  • Some users have had issues with Battleye being caught by their firewall/antivirus. Make sure Battleye is whitelisted appropriately.
  • If you are being kicked for AutoHotKey/AutoIT and can't find those programs installed on your machine, it may be because you have a program which uses those elements as a resource. Here are some common troubleshooting steps you can try:
    • Ensure that you are not running any programs can create macros or allows you to run macros. This includes some mouse drivers.
    • Ensure that you don't have old drivers installed such as outdated WiFi drivers.
    • Ensure that you are not using VmWare.
    • Some headphones and mice have AHK/AutoIT as part of their native software. Try disabling your mouse/headphone software while playing.
  • If you are experiencing a "Bad Service Version" error which kicks you out upon joining a district, this can sometimes be fixed by restarting the game or by restarting your PC.

 

Finally, as a reminder, you should avoid using any 3rd party programs to modify APB. The only approved program that doesn’t violate our TOS is the advanced launcher found here.

 

If you have tried the above and have read through the FAQ but continue to have issues, you can contact Battleye support here: https://www.battleye.com/contact/

 

Hope this helps!

 

🐝 Sakebee

  • Like 1
  • Thanks 2

Share this post


Link to post
Share on other sites

Thanks Sakebee.

 

Problem: BattlEye kicking me for AutoHotKey

Solution: Disable VPN

 

In diagnosing my issue (BattlEye kicking me for AutoHotKey, when I don't have AutoHotKey), I tried all the common solutions, and read the FAQ. The FAQ does not cover VPNs, but it does mention making sure the BattleEye executable is not blocked. It's not blocked on my machine, but that got me thinking that my VPN might be the issue. And it appears that it was. I have a sustained 30 minute connection to the server.

 

Looking for solutions to keep my VPN up, for privacy reasons, while allowing BattleEye to work.

Share this post


Link to post
Share on other sites
Posted (edited)

For the Dutchies with Ziggo Safe
edit: Or people with F-Secure
 

Problem: BEServiceprogram.zip not downloading

Solution: Disable browsing Protection OR Create website exception

 

Ziggo Safe/F-Secure is blocking from downloading because it tags it as a "Harmful website"

Edited by Leander465

Share this post


Link to post
Share on other sites
43 minutes ago, Leander465 said:

For the Dutchies with Ziggo Safe
 

Problem: BEServiceprogram.zip not downloading

Solution: Disable browsing Protection OR Create website exception

 

Ziggo Safe is blocking from downloading because it tags it as a "Harmful website"

I had the same problem with F-Secure.

Just disabled it.

  • Like 1

Share this post


Link to post
Share on other sites
Posted (edited)

Hi, I've tried every solutions on BE FAQ, nothing has worked for that issue : 

[INFO] Blocked loading of file: "C:\Program Files (x86)\Steam\steamapps\common\APB Reloaded\Binaries\APB_BEdotexe".

 

If anyone have fixed this, i'll be glad to hear the fix thank's.

Edited by Takotak

Share this post


Link to post
Share on other sites
1 hour ago, Gothina said:

I had the same problem with F-Secure.

Just disabled it.

Nice to hear. 
I know it is the sorta the same program. But I couldn't confirm.

Share this post


Link to post
Share on other sites
3 hours ago, pgilnhammer951 said:

Battleye blocked reshade uff

Reshade and shaders are not allowed.

Play the game how it is meant to be played.

 

It will look prettier in the engine upgrade, don't waste your time.

Share this post


Link to post
Share on other sites

 

WOW, things are forbidden which makes the game look better. GG, waiting for the engine update? How long should we wait? They can be happy that the APB community is still behind this snot game. One miss kick after another.Battleye blocked reshade uff

  • Like 1

Share this post


Link to post
Share on other sites
17 hours ago, Takotak said:

Hi, I've tried every solutions on BE FAQ, nothing has worked for that issue : 

[INFO] Blocked loading of file: "C:\Program Files (x86)\Steam\steamapps\common\APB Reloaded\Binaries\APB_BEdotexe".

 

If anyone have fixed this, i'll be glad to hear the fix thank's.

I am not sure but that looks like the trojan block from my antivirus Software 

I didnt felt very comfy with it but

Solution: turn any security off for installing/updating/repairing

  • Thanks 1

Share this post


Link to post
Share on other sites

Ram disc is not working.

To reduce this game shit optimization and get rid of stutter I use 16GB ram disc, and it does not work.

Giving me this massage

 

4sqELo4.png

Share this post


Link to post
Share on other sites
2 hours ago, Resine said:

Ram disc is not working.

To reduce this game shit optimization and get rid of stutter I use 16GB ram disc, and it does not work.

Giving me this massage

 

4sqELo4.png

I've got the same issue, I can launch the game without advanced launched only, but whenever I try to launch from advanced launcher i've got this error.

Share this post


Link to post
Share on other sites
4 hours ago, pgilnhammer951 said:

 

WOW, things are forbidden which makes the game look better. GG, waiting for the engine update? How long should we wait? They can be happy that the APB community is still behind this snot game. One miss kick after another.Battleye blocked reshade uff

Is an online game it isn't a singleplayer driven campaign like the last of us 2 for example, just to name you a SP game.

The only moddable mode i have in my mind right now is FiveM, but no others.

 

Online games have straight rules and you can't just change whatever you want.

Yes, indeed, things that peoples do sometimes makes the game prettier and better, but some others could break or even give more advantage over others players who aren't using them, which isn't right.

 

Engine Upgrade Should be out before september of this year, you can check out all the news regarded it here.

 

Agreed, there are many peoples i know that care about this game, one of these is me.

Isn't a miss click, is just how the game works, maybe who knows in the futuro you will be able to do that, but as of now nope.

Share this post


Link to post
Share on other sites
4 hours ago, SunnyMonroe said:

I am not sure but that looks like the trojan block from my antivirus Software 

I didnt felt very comfy with it but

Solution: turn any security off for installing/updating/repairing

That's the fix indeed, my antivirus was blocking the file, thank's 😉

Share this post


Link to post
Share on other sites

crashing randomly when purchasing a weapon/pledging to a contact with the usual crash error report window since latest patch, i just wanted to play the game :((

Share this post


Link to post
Share on other sites
31 minutes ago, 悲しい春 said:

crashing randomly when purchasing a weapon/pledging to a contact with the usual crash error report window since latest patch, i just wanted to play the game :((

If you are using a config, that's why.

Share this post


Link to post
Share on other sites
56 minutes ago, CookiePuss said:

If you are using a config, that's why.

still means the devs did something which they shouldnt have, a.k.a bug, a.k.a perfect for this thread

Share this post


Link to post
Share on other sites
1 hour ago, 悲しい春 said:

still means the devs did something which they shouldnt have, a.k.a bug, a.k.a perfect for this thread

some are saying its the localization edits... which technically aren't allowed

Share this post


Link to post
Share on other sites
5 hours ago, 悲しい春 said:

still means the devs did something which they shouldnt have, a.k.a bug, a.k.a perfect for this thread

You're using custom files that are not officially being maintained ... Pretty sure that's on you.

 

Something is added but due to your older/different files it can't load

Share this post


Link to post
Share on other sites
18 hours ago, CookiePuss said:

some are saying its the localization edits... which technically aren't allowed

It's not a localization edit. Using compat edits to alter graphic settings and get a more smoother experience on a 10 year old game that can't maintain a stable framerate on default client on hardware that has great fps in other games.

 

13 hours ago, Kevkof said:

You're using custom files that are not officially being maintained ... Pretty sure that's on you.

 

Something is added but due to your older/different files it can't load

Yeah, figured after trying to launch the game stock. Still means that people that use the adv. launcher (a.k.a majority of players) have the same problem.

Share this post


Link to post
Share on other sites
44 minutes ago, 悲しい春 said:

Yeah, figured after trying to launch the game stock. Still means that people that use the adv. launcher (a.k.a majority of players) have the same problem.

Not sure which file specifically is causing the issues, but I'm sure you can just do a clean update and then re-add the advanced launcher settings

Share this post


Link to post
Share on other sites
1 hour ago, 悲しい春 said:

Yeah, figured after trying to launch the game stock. Still means that people that use the adv. launcher (a.k.a majority of players) have the same problem.

I use the adv launcher, works fine.

Share this post


Link to post
Share on other sites
On 6/20/2020 at 10:17 PM, Shini said:

BattleEye has now started kicking for this - https://www.kovaak.com/mouse-acceleration/#:~:text=In late 2015%2C Povohat and,OS and in any game.

Was working in EAC and in the first week of BE.

If it worked the first week, and now it doesn't, it actually gives me good hope that it's being developed and improved. 

 

Hoping to see improvements. When they were still on EAC, it brought back some of my friends who left because of cheaters. 

Share this post


Link to post
Share on other sites

after this update my gpu usage jumped to a 99-100% of usage by apb only  - before that it was like 30 or smthg. what i should i check to solve this problem? 

  • Like 1

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...