Jump to content
JenzAmaka

Blue Screen of Death caused by BEDaisy.sys

Recommended Posts

Starting APB causes BSOD and the dump file says BEDaisy.sys, which is BattleEye. From what I've understood the BattleEye creates that file whenever you start the game.
I was able to avoid BSOD but I have to turn every single program off except Steam to start APB safely.
Apparently this issue only happens on Windows 7.

Other BattleEye games I tested on like PUBG or Arma 3 does not cause this problem, so something must had happened. This started 2 patches ago.
I've made support ticket but I'm making forums post anyways because this issue is scary and needs to be fixed ASAP.

Edited by JenzAmaka
  • Like 1

Share this post


Link to post
Share on other sites

I'm having this exact same problem. I'm getting a BSOD every other time I run APB. This has already once caused a corruption on my discdrive that required a system restore. @MattScott @Lixil Can you please look into this? It's quite a serious issue. I can help troubleshoot it if you need more info.

 

(or just get rid of battleye it does literally nothing anyway)

Edited by Inquitoria
  • Haha 1
  • Dislike 3

Share this post


Link to post
Share on other sites

Still happening to me. Every day.

 

EDIT: Still happening a week later (with newest patch).

Edited by Inquitoria

Share this post


Link to post
Share on other sites

Hi there,

 

My apologies.

 

We are looking into this issue. It seems to be a bad interaction between BattlEye and APB on some computers. Unfortunately. BattlEye support hasn’t been very helpful.

 

At this point we are focused on the engine upgrade which will significantly update the underying libraries of APB to 64-bit. It is our hope that the upgrade will help address issues like this.

 

Thanks,

Matt

  • Like 5

Share this post


Link to post
Share on other sites

All I can say this pisses me off so much. I'm missing all the events and everything. I really hope people who got affected by this annoyance get some compensation.

  • Haha 1

Share this post


Link to post
Share on other sites

that's what happends when you use an older gen OS 😕

 

Btw some people have have a "ERROR/Dissconnected you where kicked by battleye for the Following reason "Client is not Responding"

 

https://steamcommunity.com/app/113400/discussions/0/1735462352461823453/

 

This is a completely different issue but two fo my friends have it too

Edited by Ketog

Share this post


Link to post
Share on other sites
8 hours ago, Syzus said:

Just upgrade to Windows 8 or 10 dude

This, Windows 7 is outdated (9 years!) and isn't supported by many major companies (in a year not even by microsoft) anymore. Why would a small one have to.

 

I get the 8/10 have a shitton of telemetry and collect a lot of data so that rises privacy concerns - but that's nothing you couldn't disable. (and if there was "secret" data collection, you bet that would have also been part of/patched into win 7 too)

 

otherwise win 8/10 is superior (except some "features" like the new settings that still require you to use control center occassionally)

Edited by neophobia

Share this post


Link to post
Share on other sites
11 hours ago, Syzus said:

Just upgrade to Windows 8 or 10 dude

I would but got few things that's holding back.

Besides, I would be ok if software straight up doesn't support W7 but causing BSOD. Somethings forked up. Besides APB is old game.

Share this post


Link to post
Share on other sites

Windows 7 is still a supported platform and literally every engine in existence builds to Windows 7 just fine. Shitty excuse.

 

There has been 0 help from neither LO nor BattlEye in resolving this issue, which is insanely annoying.

Share this post


Link to post
Share on other sites

Had this too, at first I thought it was the windows insiders build I was using. Ended up re-installing windows, which fixed the issue but still a hassle. 

(Windows 10 btw)

Edited by Tessar

Share this post


Link to post
Share on other sites

Actually. Game is running fine now.

If you still have the problem try this thing.


"Go to computer in the startup menu, right click, and hit properties.
Then click "advanced system settings" and click on "Startup and Recovery" settings button.

If Memory Dump set to "Kernal dump" change it to "Small memory dump""

 

Mysterious Stranger told me this and it worked for while and stopped, but now its working again. It really depends on patches. Next patch could ruin everything.

  • Like 1
  • Thanks 1

Share this post


Link to post
Share on other sites
On 12/9/2018 at 7:44 AM, Ketog said:

that's what happends when you use an older gen OS 😕

 

Btw some people have have a "ERROR/Dissconnected you where kicked by battleye for the Following reason "Client is not Responding"

 

https://steamcommunity.com/app/113400/discussions/0/1735462352461823453/

 

This is a completely different issue but two fo my friends have it too

if not done yet, maybe create a new thread if it's a different issue

On 12/9/2018 at 1:44 PM, Inquitoria said:

Windows 7 is still a supported platform and literally every engine in existence builds to Windows 7 just fine. Shitty excuse.

 

There has been 0 help from neither LO nor BattlEye in resolving this issue, which is insanely annoying.

supported by whom?

ms is providing updates for only one more year.

intel and amd stopped supporting it already.

my argument stands.

 

this does not appear like an engine issue either.

 

true, there has been no solution provided officially.

but there has been help by the community - and it is the most obvious and reasonable solution - update to w10.

 

if you can't - well, people with a mac or linux can't play either if they stay on those OS.

Share this post


Link to post
Share on other sites

Im having the exact same problem here on Windows 7. Sometimes its Driver overran stack based buffer and one time I had a bluescreen with ram error..only happening with APB.. the ram Bsod happened on OTW client yesterday after I got stuck at district spawn loading and closed the game with task manager and then restarted it.

Sometimes it works fine and sometimes Bsod on apb start right after the spash screen opens :S

This never happenend to me before like 2 weeks ago so I assume its maybe caused by one of the last patches that cause this Battleye Bsod for win7 users.

Can a Mod tell about this to Matt again pls?

Share this post


Link to post
Share on other sites
On 5/12/2019 at 12:31 PM, UltraMES187 said:

Im having the exact same problem here on Windows 7. Sometimes its Driver overran stack based buffer and one time I had a bluescreen with ram error..only happening with APB.. the ram Bsod happened on OTW client yesterday after I got stuck at district spawn loading and closed the game with task manager and then restarted it.

Sometimes it works fine and sometimes Bsod on apb start right after the spash screen opens :S

This never happenend to me before like 2 weeks ago so I assume its maybe caused by one of the last patches that cause this Battleye Bsod for win7 users.

Can a Mod tell about this to Matt again pls?

This might not be fully fixed until the engine upgrade, plus I hear that Windows 7 will lose support from Microsoft soon, so you might want to consider upgrading your OS.

Share this post


Link to post
Share on other sites

Win 7 have alot of HOLES that cheaters uses if some program uses program/dll library or simmilar that is flagged by BE as cheating entry then u need to remove this app from running on win 7

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...