Jump to content
Tobii

[BUG] 145 fps causing floating/sliding movement

Recommended Posts

Summary: 145 fps causing floating/sliding movement

Description: When your FPS is above the old cap, micro movement will cause you to slide/float for a second up to a few seconds. When I forced my game below 120, it did not happen.



Steps to Reproduce:
1. Have stable or almost stable 145 fps.
2. Move in any direction.

How many times have you recreated this bug: 95/100

Results: You're moving with no input.

Expected Results: I shouldn't move when I release the button.. Edited by Tobii
  • Like 2
  • Thanks 2

Share this post


Link to post
Share on other sites

Yeah I figured it'd be down to the 145fps cap, didn't something similar (Iow gravity or whatever?) happen way back around RTW times when they tried unlimiting fps?

Edited by Kiida
  • Like 1

Share this post


Link to post
Share on other sites
3 hours ago, Kiida said:

Yeah I figured it'd be down to the 145fps cap, didn't something similar (Iow gravity or whatever?) happen way back around RTW times when they tried unlimiting fps?

pretty sure that was server FPS.
  • Like 1

Share this post


Link to post
Share on other sites

Sure wish my game was this fluid. 😞 May I ask what settings do you have and on which rig you're running it?

Edited by Solista2050

Share this post


Link to post
Share on other sites
1 hour ago, Solista2050 said:

Sure wish my game was this fluid. 😞 May I ask what settings do you have and on which rig you're running it?

1080 Ti + 8770k @ 4.8 Ghz.
And then my own config.
  • Like 1

Share this post


Link to post
Share on other sites
1 hour ago, MrsHappyPenguin said:

Weird. I'm trying to reproduce this but can't. Do you happen to have a controller plugged in?

I do not.

Other people have the same issue so it's not just me.
  • Like 1

Share this post


Link to post
Share on other sites

I joined an empty waterfront district and this bug shown it's face. I could reproduce it every single time I stopped moving.

Share this post


Link to post
Share on other sites

So here's what I've found. If I'm recording with OBS, my fps goes down by 1, from 145 to 144. This stops the sliding. I don't think the high fps is the issue, it seems to be the framerate limiter itself that's causing it.

It wouldn't be an issue if my weapon wasn't stuck with maximum bloom.

Also, THIS EDITOR IS A POS!

Edited by MrsHappyPenguin

Share this post


Link to post
Share on other sites

I doubt it's the limiter, seeing as the old cap didn't cause this.
It's most likely cause by the new client FPS in some way.

It's hard to say exactly what is going on but it is easy to reproduce at this point.

Share this post


Link to post
Share on other sites

Bumping this incase the devs missed it.

 

Here's a workaround for those who have this issue.

 

Open the file "BaseEngine.ini", located in "\APB Reloaded\Engine\Config\"

Change the line MaxSmoothedFrameRate=62, to MaxSmoothedFrameRate=121

Launch APB using the APB.exe.

Enable smooth framerate in the graphics options.

Edited by MrsHappyPenguin
  • Like 1
  • Thanks 1

Share this post


Link to post
Share on other sites

I fixed this bug by locking the game to 144fps, it happens for me when the game hits 144.1fps

Share this post


Link to post
Share on other sites
3 hours ago, Lign said:

I fixed this bug by locking the game to 144fps, it happens for me when the game hits 144.1fps

Not so much a fix since the FPS is capped at 145..

Surprised they haven't commented on this at all.. /shrug

Share this post


Link to post
Share on other sites
50 minutes ago, Tobii said:

Not so much a fix since the FPS is capped at 145..

Surprised they haven't commented on this at all.. /shrug

I capped it in Nvidia Inspector

Share this post


Link to post
Share on other sites
12 hours ago, Lign said:

I capped it in Nvidia Inspector

There is a few ways to cap. What I mean is that this should be fixed by LO.

Just lower the FPS by one if that is all it takes..

Share this post


Link to post
Share on other sites
1 hour ago, Tobii said:

There is a few ways to cap. What I mean is that this should be fixed by LO.

Just lower the FPS by one if that is all it takes..

For some reason sometimes the game jumps up to 144.1-144.5, and it causes me getting the bug, but it's still better than getting it constantly

Share this post


Link to post
Share on other sites

Good lord this has been reported since a little while...are they in need of more evidences?! It's quite a major bug imo.

 

@Selali@Lixil

 

Notice this pls! ❤️ 

Share this post


Link to post
Share on other sites

I know this is a really old post but this issue is still present as of today

Share this post


Link to post
Share on other sites

u've been hit by
u've been hit byyy

 

....A smooth crim-- enforcer.

 

jokes apart, i wonder if this slight movement actuality has some affect in ur position, seen by others.

Share this post


Link to post
Share on other sites
Guest

Happening to me often, is annoying, alredy reported but meh, the support is dead.

Share this post


Link to post
Share on other sites

The issue is still present. It does not happen all the time. You can use a custom config or Rivatuner to lock your framerate to 121fps. Any higher and this bug will happen randomly.

Share this post


Link to post
Share on other sites
11 hours ago, Bellenettiel said:

jokes apart, i wonder if this slight movement actuality has some affect in ur position, seen by others.

It does. People move the same way as in the clip.

Edited by Tobii

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...