Jump to content

Recommended Posts

Triksterism's suggest provides less input lag, but if you don't want to mess with the Nvidia profiles you can do this:

Open the BaseEngine.ini (APB Reloaded\Engine\Config).
Find this line: "MaxSmoothedFrameRate=62"
Change it to: "MaxSmoothedFrameRate=121". You can set this to almost any value under 145fps.
In game, enable smooth frame rate. Your fps should now be capped to 121.

I have had way smoother FPS since the last patch. I still get the stuttering from the garbage collection, but otherwise no complaints. I did notice that Dynamic Shadows have a small impact on fps when there's a lot of transparent objects in view, like when overlooking the park on Financial. You could try disabling them.

Edited by MrsHappyPenguin

Share this post


Link to post
Share on other sites
6 hours ago, kolaman91 said:

They should add a FPS Limit option similar to Fortnite's where you can choose your desired limit. Not sure if this is possible with APB's current engine, but it would be nice if you could set it past your monitors refresh rate like Fortnite and other games.

This.

Share this post


Link to post
Share on other sites

High framerate used to be an issue in UE3, namely with networking performance.

Plus...
Why would you want your PC to use more CPU cycles when it doesn't have to? More framerate isn't going to stop the poor threading done in code by UE3. It's going to make it worse. The human eye definitely can't see past 120hz.

Share this post


Link to post
Share on other sites
1 hour ago, Sophiie said:

High framerate used to be an issue in UE3, namely with networking performance.

Plus...
Why would you want your PC to use more CPU cycles when it doesn't have to? More framerate isn't going to stop the poor threading done in code by UE3. It's going to make it worse. The human eye definitely can't see past 120hz.

Go back to Xbox you peasant!

Share this post


Link to post
Share on other sites
1 hour ago, Sophiie said:

High framerate used to be an issue in UE3, namely with networking performance.

Plus...
Why would you want your PC to use more CPU cycles when it doesn't have to? More framerate isn't going to stop the poor threading done in code by UE3. It's going to make it worse. The human eye definitely can't see past 120hz.

High FPS is about reducing input lag, which is why it can feel beneficial, even if your monitor can't display the extra frames in between. How many frames your eyes are seeing is not that relevant, it's how much of the delay you can see / feel from when you move your mouse to when the screen updates.

Share this post


Link to post
Share on other sites
6 hours ago, TackoGirl said:
Tell me your pc datas, i can't believe it. :,D
I still want my 120 fps back... this has worked for me fine.
7700k
1080
16gb
500gb ssd
1080P 144hz monitor

and nope none overclocked .-.

Share this post


Link to post
Share on other sites
5 hours ago, JiMMY13 said:
8 hours ago, Sophiie said:

High framerate used to be an issue in UE3, namely with networking performance.

Plus...
Why would you want your PC to use more CPU cycles when it doesn't have to? More framerate isn't going to stop the poor threading done in code by UE3. It's going to make it worse. The human eye definitely can't see past 120hz.

High FPS is about reducing input lag, which is why it can feel beneficial, even if your monitor can't display the extra frames in between. How many frames your eyes are seeing is not that relevant, it's how much of the delay you can see / feel from when you move your mouse to when the screen updates.

Inputs go off regardless of the rendering thread. It gets processed the next frame with the actions of whatever happens in the main thread. UE3 has two different threads, and one is separate from the main thread. Inputs are also processed on their own thread, at least they are in dinput.

So if you input a left mouse click, it won't actually trigger the delegate associated with that left mouse click until the system sends that window event to the process. Which won't happen until the next loop in the main thread.

But - if we're rendering thousands of frames per second, input delay will actually be too quick and have varying delays because the frame being rendered may take priority over the main thread. Whereas if you cap at a stable framerate (ie; a minimum of 10 below the max fps value observed uncapped) you'd actually have more stable and reliable inputs due to less wasted CPU cycles on rendering without reason.

Let's say your framerate uncapped fluxes to 500...
You'd want to put it at 450 - that way, you don't over-budget your CPU, if you know you always can get 450 FPS.
You never want to go below the server's framerate, ideally. The client will have to play catchup constantly otherwise, even if it's for a little bit of time. If you're spiking due to UE3's rendering thread blocking the game thread somehow (which is the case in APB a *lot*) you'll actually end up with worse input lag, some stuttering and the networking layer will be less reliable.

Back in the day, that was 30 fps for APB when we had fpsdetail. Don't know what it is now, but stable FPS above 30 and ideally 10 fps below your maximum observed framerate would be ideal.

Share this post


Link to post
Share on other sites
On 8/12/2018 at 1:25 AM, MrsHappyPenguin said:

Triksterism's suggest provides less input lag, but if you don't want to mess with the Nvidia profiles you can do this:

Open the BaseEngine.ini (APB Reloaded\Engine\Config).
Find this line: "MaxSmoothedFrameRate=62"
Change it to: "MaxSmoothedFrameRate=121". You can set this to almost any value under 145fps.
In game, enable smooth frame rate. Your fps should now be capped to 121.

I have had way smoother FPS since the last patch. I still get the stuttering from the garbage collection, but otherwise no complaints. I did notice that Dynamic Shadows have a small impact on fps when there's a lot of transparent objects in view, like when overlooking the park on Financial. You could try disabling them.

Have you measured the input lag to make such a statement? Usually FPS limiters outside of the game are causing more input latency than inbuilt frame limiters, but of course this depends on how the inbuilt frame limiter itself works. Edited by trismatic

Share this post


Link to post
Share on other sites

Mine runs perfect at a constant 60 fps, just limit ur fps in the .ini

Share this post


Link to post
Share on other sites
On 8/11/2018 at 12:04 PM, TackoGirl said:

please Little Orbit, @MattScott 
you have lifted the 120 FPS limit to 145FPS for all who have a monitor for it.
Now i have a lot of FPS problems because my PC always tries to reach the 145 FPS.
I would like to play again with my "constant" 120 fps. this is not possible anymore even if you set your screen to 120 hz it still stays at 145 FPS in the game.
It would be really great if they could change that.

if you set screen to 100hz earlier you had a limit of 100 FPS if you set it to 120hz, you had a limit of 120FPS, now you cant change it.

a few weeks ago I overclocked my cpu so that I have "constant" 120 fps.... and now i have big FPS problems, because i can not reach the 145. it drops from 120 to 133 145 back to 110, That feels really shitty

 
tnpgd3la.jpguk4xvo5o.jpg    
How much more fps do you really need for apb?? Just asking not trying to be an patootie.
On 8/11/2018 at 12:04 PM, TackoGirl said:

please Little Orbit, @MattScott 
you have lifted the 120 FPS limit to 145FPS for all who have a monitor for it.
Now i have a lot of FPS problems because my PC always tries to reach the 145 FPS.
I would like to play again with my "constant" 120 fps. this is not possible anymore even if you set your screen to 120 hz it still stays at 145 FPS in the game.
It would be really great if they could change that.

if you set screen to 100hz earlier you had a limit of 100 FPS if you set it to 120hz, you had a limit of 120FPS, now you cant change it.

a few weeks ago I overclocked my cpu so that I have "constant" 120 fps.... and now i have big FPS problems, because i can not reach the 145. it drops from 120 to 133 145 back to 110, That feels really shitty

 
tnpgd3la.jpguk4xvo5o.jpg    
Nvm i just read the post again, don't mind me already have a good amount of beers...but on to other things. I reach 145 fps lowest it dips down to is 120. that'f with my 145hz monitor@1440p also i doubt overclocking your cpu will cause fps issues, at least i have not had this problem with gaming up to this day, id say check your settings again and see if something looks odd. Edited by B0N3EZ

Share this post


Link to post
Share on other sites
11 hours ago, trismatic said:
Have you measured the input lag to make such a statement? Usually FPS limiters outside of the game are causing more input latency than inbuilt frame limiters, but of course this depends on how the inbuilt frame limiter itself works.

The smooth framerate option adds a bit of input lag which is why I said that.

Share this post


Link to post
Share on other sites
21 minutes ago, MrsHappyPenguin said:
The smooth framerate option adds a bit of input lag which is why I said that.

I don't have any idea how the smoothframerate is implemented. But external framelimiters almost always cause more input latency than inbuilt ones.

Share this post


Link to post
Share on other sites
10 hours ago, B0N3EZ said:
How much more fps do you really need for apb?? Just asking not trying to be an patootie. Nvm i just read the post again, don't mind me already have a good amount of beers...but on to other things. I reach 145 fps lowest it dips down to is 120. that'f with my 145hz monitor@1440p also i doubt overclocking your cpu will cause fps issues, at least i have not had this problem with gaming up to this day, id say check your settings again and see if something looks odd.
with my cpu is all great, the only thing what i have to do is wait, matt say he fix it. 

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...