Jump to content
wayofthinking

FPS drops and objects pop ups

Recommended Posts

Hello,

 

I have two problems. The first one is, I have fps problems.

My PC should handle this game easily, but I have fps drops every few seconds.

I dunno why, maybe you can help me.

 

PC specs:

i7 7700k

32gb RAM

GTX 1080Ti

144hz display

 

Second problem: 

The objects ingame are popping up constantly, even cars are popping up.

It feels like theres a really short render distance. Graphics setting is the highest.

Is there any way to fix it?

 

I hope you can help, because I really want to play this game.

 

Best regards,

wayofthinking

Edited by wayofthinking

Share this post


Link to post
Share on other sites

The fps thing is with everyone it seems, just the servers being doody from the DDOS lately.

 

As for stuff popping up..I have no idea

Share this post


Link to post
Share on other sites
Just now, PancakePower said:

The fps thing is with everyone it seems, just the servers being doody from the DDOS lately.

The thing is, I already tried the game many times. And everytime I have these fps drops. 

I think it's the third time I wanna try out the game. Between these tries were a few months I think.

Share this post


Link to post
Share on other sites

With these specs u must have 121 fps constantly... idk how on earth you having those fps drops ;o

Try to lower your settings ...

 

Maybe try advanced launcher and lower some settings ;o

 

Edited by Edwinke

Share this post


Link to post
Share on other sites

unpark your cpu's cores, that could help.

Edited by PoshDoll

Share this post


Link to post
Share on other sites
34 minutes ago, PoshDoll said:

unpark your cpu's cores, that could help.

Only for windows 7.

This was fixed in windows 8 and up.

3 hours ago, wayofthinking said:

 

SSD or HDD?

Share this post


Link to post
Share on other sites

It's running on a HDD atm, but I can play games like The Witcher 3 on my HDD too, without any objects pop ups or fps drops?

Edited by wayofthinking

Share this post


Link to post
Share on other sites

That's called optimization. Something APB's been struggling with for quite some time.

I would try to move it over to your SSD if you have one, and see if that helps.

 

There used to be a lot of guides on the forum, but I don't remember exactly what they suggested.

Edited by Tobii

Share this post


Link to post
Share on other sites

Alright, game is on my ssd now.

Objects, cars, NPCs are still popping up, it's like the render distance is capped at 100 meters.

FPS drops are still a thing.

Share this post


Link to post
Share on other sites

the game uses CPU power more than GPU, so if your CPU is doing multiple things at once it will hinder APBr.

 

 

the object popping should really only account to NPCs because they sort of just spawn. I would recommend using the advanced launcher as it can stop the pop ups afaik.

 

I have used the launcher since forever, and I don't get any sort of pop ups.

Share this post


Link to post
Share on other sites

What Nvidia setting are you set with in the control panel. I had similar issues when editing the advanced settings.

 

Most of the time when I think about objects popping up its based off the LOD and the view distance setting built in the game. I would say that's normal

 My Config

_______________

I7-6700k 4.0 Clock

16Gb Ram - 3000mhz

Nvidia Gtx 980 - Ti

 

Advanced 3d Image settings.

___________________

Ambient Oclussion - Off

Anistrofic FIltering - Application Controlled

Antiailiasing FXAA - Off

Antiailiasing Gamma Correction - On

Antiailiasing Mode - Application Controlled

Antiailiasing Transparency - Off

Cuda Cores - All

DSR Factors - Off

DSR Smoothness - Off

Maximum-Pre Rendered Frames - 3

Multi-Frame Sampled AA (MFAA) - Off

OpenGL Rendering GPU - Your Graphics card

Optomize for Computer Performance - Off

Power Management Mode - Prefer Maximum Performance

Shader Cache - On

Texture Filtering Anistropic Optimization  - Off

Texture Filtering Negative Lod Bias - Allow 

Texture Filtering Quality - Quality

Texture Filtering Trilinier Optimization - On

Threaded Optomization - Auto

Triple Buffering - Off

Virtual Sync - Off

Virtual Reality Pre-Rendered Frames - 3

 

In Game Settings

______________

Basic

____

Resolution 1920x1080p

Vsync - Off

Smooth Frame Rate - Off

Multi GPU Compatability - On 

 

Advanced

_________________

Static Decals - On

Dynamic Shadows - On

Light Environment Shadows - On

Blob Shadows - On

Ambient Occlusion - Off

Distortion - Off

Trilinear Mip Filtering - On

Low Quality Health Hud - Off

Render Eye Lashes - On

Anistropic - Disabled

Anti Aliasing - Disabled

 

Ini Changes for me

_______________

Auto sprint

Hold to crouch

In both .ini files - OneFrameThreadLag = 0  

 

Any suggestions, or changes I can make. Let me know

Edited by IRyanI

Share this post


Link to post
Share on other sites
20 minutes ago, wayofthinking said:

Alright, game is on my ssd now.

Objects, cars, NPCs are still popping up, it's like the render distance is capped at 100 meters.

FPS drops are still a thing.

Well, the game is limited to 100m when it comes to players. That's it though.

Can you give an example of the actual problem?

Are you running in fullscreen mode? Do you have any temperature monitoring on?

 

Also not sure this place is correct for this kind of question, seeing as it's prob a bug/issue of some kind.

Should maybe get it moved.

Share this post


Link to post
Share on other sites
19 minutes ago, Obvious Lesbian said:

the game uses CPU power more than GPU, so if your CPU is doing multiple things at once it will hinder APBr.

I don't think it's a CPU problem. CPU usage is only at 35% while playing.

 

20 minutes ago, IRyanI said:

What Nvidia setting are you set with in the control panel. I had similar issues when editing the advanced settings.

I use the default options.

I already tried the advanced launcher, set everything to maximum, but still no changes.

 

10 minutes ago, Tobii said:

Well, the game is limited to 100m when it comes to players. That's it though.

Can you give an example of the actual problem?

Are you running in fullscreen mode? Do you have any temperature monitoring on?

Well, I can't upload a video, because my upload is trash.

Here is a picture, I hope you know now what I mean.

 

ddddddddddddd.png

As you can see, on the upper picture you can't see the car.

I moved 1-2 meters forward and the car popped up.

I dunno if it's just the game, but it's strange how short the render distance is.

Specially while driving these pop ups are a bit .. well, not beneficial.

 

I tried both fullscreen or windowed fullscreen, no difference. Temperatures are fine.

 

 

 

Share this post


Link to post
Share on other sites
1 minute ago, wayofthinking said:

 

ddddddddddddd.png

As you can see, on the upper picture you can't see the car.

I moved 1-2 meters forward and the car popped up.

I dunno if it's just the game, but it's strange how short the render distance is.

Specially while driving these pop ups are a bit .. well, not beneficial.

 

I tried both fullscreen or windowed fullscreen, no difference. Temperatures are fine.

 

 

 

 

no bro. That is the game.

 

I thought you meant actual pop ups.

 

This game was made in 2009. Don't expect it to be super amazing.

Share this post


Link to post
Share on other sites
4 minutes ago, wayofthinking said:

I don't think it's a CPU problem. CPU usage is only at 35% while playing.

 

I use the default options.

I already tried the advanced launcher, set everything to maximum, but still no changes.

 

Well, I can't upload a video, because my upload is trash.

Here is a picture, I hope you know now what I mean.

 

ddddddddddddd.png

As you can see, on the upper picture you can't see the car.

I moved 1-2 meters forward and the car popped up.

I dunno if it's just the game, but it's strange how short the render distance is.

Specially while driving these pop ups are a bit .. well, not beneficial.

 

I tried both fullscreen or windowed fullscreen, no difference. Temperatures are fine.

 

 

 

That's absolutely the game. that is not a problem on your side. its basic optimization

Share this post


Link to post
Share on other sites
6 minutes ago, wayofthinking said:

Alright, good to know.

 

One "problem" solved. FPS drops are still a thing 😞

You have to check what you have running.

Are you in windowed mode? Do you have anything running in the background?

Just saying "I have low FPS" doesn't give us much to go with.

Share this post


Link to post
Share on other sites

Have you tried to "reapply" the settings? 

It's definitely something on your end because I'm running it on 8700k@4.9GHz  stable 101fps 1080p ...and old old mechanical drive.

Share this post


Link to post
Share on other sites

//double post...without even clicking twice. Nice. Maybe a mod can delete it.

Edited by Sayori

Share this post


Link to post
Share on other sites
6 hours ago, Tobii said:

You have to check what you have running.

Are you in windowed mode? Do you have anything running in the background?

Just saying "I have low FPS" doesn't give us much to go with.

I already said I tried different window modes. My CPU usage is at 35% while playing, so no, I don't have anything heavy cpu eating in the background.

I also said I already tried the advanced launcher without improvements.

 

Apparently you didn't read my posts, I said many things and not just "I have low fps"

 

4 hours ago, Sayori said:

Have you tried to "reapply" the settings? 

It's definitely something on your end because I'm running it on 8700k@4.9GHz  stable 101fps 1080p ...and old old mechanical drive.

What do you mean with "reapply" the settings?

 

Edited by wayofthinking

Share this post


Link to post
Share on other sites
1 hour ago, wayofthinking said:

I already said I tried different window modes. My CPU usage is at 35% while playing, so no, I don't have anything heavy cpu eating in the background.

I also said I already tried the advanced launcher without improvements.

 

Apparently you didn't read my posts, I said many things and not just "I have low fps"

 

What do you mean with "reapply" the settings?

 

/shrug.

You ignored me asking if you have any temp MONITORING software running.. but well.

I guess neither of us read.

 

You didn't mention what Windows version you're on either.

Seeing as someone suggested you should try and unpark cores.

 

I would reinstall the game, check if that makes a difference.

If not, remove drivers with DDU.

If it's the same, Malwarebytes.

And if nothing whatsoever works, format your PC.

Edited by Tobii

Share this post


Link to post
Share on other sites
1 hour ago, wayofthinking said:

I already said I tried different window modes. My CPU usage is at 35% while playing, so no, I don't have anything heavy cpu eating in the background.

I also said I already tried the advanced launcher without improvements.

 

Apparently you didn't read my posts, I said many things and not just "I have low fps"

 

What do you mean with "reapply" the settings?

 

Open the options menu, select a different graphics quality option, apply, restart the game, see if this makes any difference.

If not, try what Tobiii said. I've tried MSI afterburned with OSD on after Battleye patch and there are no issues. 

I'd not go that far to reinstall Windows though.

Edited by Sayori

Share this post


Link to post
Share on other sites
9 hours ago, wayofthinking said:

Alright, game is on my ssd now.

Objects, cars, NPCs are still popping up, it's like the render distance is capped at 100 meters.

FPS drops are still a thing.

The render distance can't be changed.

 

Gotta remember, this game is a decade old.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...