Jump to content
Sign in to follow this  
killerskull

APB Wont Run - DEP Error - No Fix

Recommended Posts

I guess I know why people wont try out apb, because they cant play after installing. 

 

Error window tells me to enable DEP for all programs, which Ive done and restarted. I try to run it and I still get the error. So yea, I cant play apb.

 

This forum has always been slow as well. I just pressed the button once and got an error msg. I reloaded the page and there are 2 topics made.

Edited by killerskull

Share this post


Link to post
Share on other sites

- can u provide image of error?

- is your os up to date?

- what ur os is?

- is ur drivers are up to date...

* myself DEP is off for all. (only win7 pro all up-to-date all run-times)

ALL u missed it's not everyone in this world

I have lots of ppl who play game for 4y and no issues. seems to me all updates need to be done but G1 did fuck all! so take a time

Edited by Dahel

Share this post


Link to post
Share on other sites

Win 10

 

New fresh install, windows have been updated to the latest version. I had the game installed every since g1 apb came out of beta, never had an issue. But Im installing now on win 10 and getting this error. Nvr had an ussue on win 7.

Edited by killerskull

Share this post


Link to post
Share on other sites

A lot of people who have been playing are not able to play now.  My suspicion is that it revolves around AMD CPUs and the patching implementation of BattleEye.  I could be wrong but a lot of people suddenly having major issues logging in and getting kicked are the ones using AMD processors.

Share this post


Link to post
Share on other sites

I have CCleaner and Glary and have run them, that isn't my problem.

Share this post


Link to post
Share on other sites

Windows key -> cmd -> right click -> "Run as Admin" -> bcdedit /set {current} nx AlwaysOn -> Reboot

 

The "nx" option tells the OS whether or not DEP is enabled, if you don't trust what I'm saying then feel free to take a look around on Google before entering cmd commands mindlessly, all it does is set the current boot option's "nx" (DEP) to AlwaysOn (default is OptIn), feel free to read up on it here as well.

 

https://support.microsoft.com/en-us/help/875352/a-detailed-description-of-the-data-execution-prevention-dep-feature-in

Edited by Similarities

Share this post


Link to post
Share on other sites
18 minutes ago, Similarities said:

Windows key -> cmd -> right click -> "Run as Admin" -> bcdedit /set {current} nx AlwaysOn -> Reboot

 

The "nx" option tells the OS whether or not DEP is enabled, if you don't trust what I'm saying then feel free to take a look around on Google before entering cmd commands mindlessly, all it does is set the current boot option's "nx" (DEP) to AlwaysOn (default is OptIn), feel free to read up on it here as well.

 

https://support.microsoft.com/en-us/help/875352/a-detailed-description-of-the-data-execution-prevention-dep-feature-in

 

The error msg suggested that OR manually doing it thru advanced settings. I HAVE enabled DEP for everything thru advanced settings. Going thru cmd is the shorter route. So I dont think I messed up that step. I could however retry it but thru cmd this time. Im not sure how that would help since DEP is enabled for everything. 

Share this post


Link to post
Share on other sites
1 minute ago, killerskull said:

 

The error msg suggested that OR manually doing it thru advanced settings. I HAVE enabled DEP for everything thru advanced settings. Going thru cmd is the shorter route. So I dont think I messed up that step. I could however retry it but thru cmd this time. Im not sure how that would help since DEP is enabled for everything. 

This force enables it on every single program that runs, it's worth a shot even if you think you've done everything properly because it completely cuts out any user error (except for possibly entering the command incorrectly), if it still fails, it has to be a bug because it's literally impossible for it to fail with the nx AlwaysOn option.

Share this post


Link to post
Share on other sites
 
Go to DEP (Data Execution Prevention) and grant an exception for the game  In case you don't know how to do this: 


To add a program to the DEP Exception List 
1.) Open "Control Panel" 
2.) Click on "System and Maintenance" 
3.) Click on "System" 
4.) On the left side click on "Advanced System Settings" 
you will be asked for permission to continue, click continue 
5.) Click on the Advanced tab and then on "Settings" in the Performance area 
6.) Click on the DEP (Data Execution Prevention) tab 
7.) Put a tick in the little circle next to "Turn on DEP for all programs and services 
except those I select" and click on the "ADD" button and 
browse for and click on the program file for the game, then click "Open" now click "Apply" then "OK" 
and close all open windows and your done.

Share this post


Link to post
Share on other sites
3 hours ago, Similarities said:

This force enables it on every single program that runs, it's worth a shot even if you think you've done everything properly because it completely cuts out any user error (except for possibly entering the command incorrectly), if it still fails, it has to be a bug because it's literally impossible for it to fail with the nx AlwaysOn option.

 

Ok, thanks, Ill try this out tomorrow.

2 hours ago, SixxstagesofMajik said:
 
Go to DEP (Data Execution Prevention) and grant an exception for the game  In case you don't know how to do this: 


To add a program to the DEP Exception List 
1.) Open "Control Panel" 
2.) Click on "System and Maintenance" 
3.) Click on "System" 
4.) On the left side click on "Advanced System Settings" 
you will be asked for permission to continue, click continue 
5.) Click on the Advanced tab and then on "Settings" in the Performance area 
6.) Click on the DEP (Data Execution Prevention) tab 
7.) Put a tick in the little circle next to "Turn on DEP for all programs and services 
except those I select" and click on the "ADD" button and 
browse for and click on the program file for the game, then click "Open" now click "Apply" then "OK" 
and close all open windows and your done.

 

Thanks, if the solution above doesnt work, Ill add the exception. Ive already done the add all but havnt added apb to exceptions.

 

Share this post


Link to post
Share on other sites

I do hate win10 coz their updates and non user friendly environments, all info send to their servers... spying, lots of services and processes not for user, toxic scrap 

so I've downgraded win10 to win7 for those reasons. 

OS 10 have own life! like a pet at your home, updates installed with a force, no user asking. ok, but those updates we do not need, makes worst for user, but who cares about users.

(political dumb, Wests fights with Easts, info war)

Edited by Dahel

Share this post


Link to post
Share on other sites
4 hours ago, ElectroStingz said:

Hello,

 

What CPU and motherboard are you using?

 

 

i5 4670k and PZ77-something I dont remember. 

 

I upgraded to win 10 even tho I didnt want to because there are games that will only run on win 10, like state of decay. So I had to. Win 10 and 7 you can disable auto updates.

Share this post


Link to post
Share on other sites

Try CPUz and check both your board / CPU

https://www.cpuid.com/softwares/cpu-z.html

 

Reason I ask, depending on what you have there is likely an issue with compatibility under Windows 10.

An older board / BIOS may not comply to what the newer standards are in Windows 10, a lot of this relates to hardware based security measures, Windows 10 Secure boot / UEFI.

 

Knowing what motherboard you have may lead to finding a newer BIOS (if one exists) that may help.

Share this post


Link to post
Share on other sites
19 hours ago, Similarities said:

Windows key -> cmd -> right click -> "Run as Admin" -> bcdedit /set {current} nx AlwaysOn -> Reboot

 

The "nx" option tells the OS whether or not DEP is enabled, if you don't trust what I'm saying then feel free to take a look around on Google before entering cmd commands mindlessly, all it does is set the current boot option's "nx" (DEP) to AlwaysOn (default is OptIn), feel free to read up on it here as well.

 

https://support.microsoft.com/en-us/help/875352/a-detailed-description-of-the-data-execution-prevention-dep-feature-in

 

This did not work.

 

17 hours ago, SixxstagesofMajik said:
 
Go to DEP (Data Execution Prevention) and grant an exception for the game  In case you don't know how to do this: 


To add a program to the DEP Exception List 
1.) Open "Control Panel" 
2.) Click on "System and Maintenance" 
3.) Click on "System" 
4.) On the left side click on "Advanced System Settings" 
you will be asked for permission to continue, click continue 
5.) Click on the Advanced tab and then on "Settings" in the Performance area 
6.) Click on the DEP (Data Execution Prevention) tab 
7.) Put a tick in the little circle next to "Turn on DEP for all programs and services 
except those I select" and click on the "ADD" button and 
browse for and click on the program file for the game, then click "Open" now click "Apply" then "OK" 
and close all open windows and your done.

 

After trying the above solution, I cant select any option anymore. The boxes are faded out.

 

3 hours ago, ElectroStingz said:

Try CPUz and check both your board / CPU

https://www.cpuid.com/softwares/cpu-z.html

 

Reason I ask, depending on what you have there is likely an issue with compatibility under Windows 10.

An older board / BIOS may not comply to what the newer standards are in Windows 10, a lot of this relates to hardware based security measures, Windows 10 Secure boot / UEFI.

 

Knowing what motherboard you have may lead to finding a newer BIOS (if one exists) that may help.

 

Z97-A is the mobo. GTX 770. i5 4690k

 

https://www.asus.com/ca-en/Motherboards/Z97A/HelpDesk_Download/

 

I dl the BIOS which is a .CAP. But i dunno what to do with it.   Screw this, Im not flashing or anything to my BIOS. Its good and hasnt given any problems.

 

This is stupid, why is it so hard to run this game? Ive never had this issue with other online games.

Edited by killerskull

Share this post


Link to post
Share on other sites

I'll post this in the event that you wish to try a few things, yes flashing a BIOS is always a risk but it rarely goes wrong.

The BIOS CAP file needs to be copied to a flash drive, FAT32 formatted.

You then enter the BIOS and choose the EZ Flash option.

 

My own take on this, you should try the BETA BIOS listed, this is also linked to a bug which you may have seen floating around, "Spectre & Meltdown".

Both related to the hardware security features associated with DEP / NX bit.

 

Once the BIOS is flashed, see if APB runs. If not change your BIOS to UEFI but please note the following points below.

 

==============

 

Everything I mention below may have a knock on effect and cause you futher issues.

When you change the Bios option to UEFI you will need to re-install Windows 10.

And it changes how the boot devices are detected, if only 1 drive you are likely to be OK.

 

==============

 

For a fully compliant Windows 10 install you need to set an your BIOS to UEFI mode.

In your BIOS options, Boot, you should have somewhere the ability to set the: OS Type [Windows UEFI Mode]

Is it set to: [Windows UEFI Mode]

 

Please note if you change this option you will need to reinstall Windows 10.

 

==============

 

Knock on effect of UEFI mode, your GFX card GTX770 if this was released at the time of Windows 8 it will likely work.

If not, when you set to UEFI mode in your BIOS and save&Exit, it may stop working / blank screen.

Should this happen, your only option is to reset your BIOS. (clear CMOS jumper / remove battery / short some pins, refer to the manual.)

 

==============

 

If you get this far and APB still does not work 😞 something is broken.

Share this post


Link to post
Share on other sites

Do NOT flash BIOS until get permission from manufacturer. or use local PC workshop to do so and collect all receipts to have legal actions against technical if they fucked up your MB. 

state of decay playable on osXP-os7.

I cannot understand update to os10, "not all game run under os7" -> not true. 

 

***Installing windows from unknown source (image), NOT official versions or BUILD-EDIT by users or groups

---->>> CAUSES errors and PC health under risk. no matter who said "im ok under user build" he do not know what doing.

all official version builds can be found click "here"

Edited by Dahel

Share this post


Link to post
Share on other sites
7 hours ago, SixxstagesofMajik said:

Right click the program file 
GO to propeties
Compatibility >Run this program for windows ? > ? being what choose try windows 7
 

 

This is the only other thing I can think off. Either this or install thru steam and try. I think it wont help.

 

I do not want to flash my bios. Ive contacted spport 2 days ago, lets see what they say. 

 

eDIT: Making it compatible to win 7 did nothing. No apb for me then. Support still hasnt gotten back to me and I have a feeling they will be of no help. 

Edited by killerskull

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...