Jump to content



  • Please log in to reply
No replies to this topic




  • Members
  • 1 posts
  • Joined 07-November 12

hmm, well; tried it without steam and with steam, tried adding exceptions, not able to address router, so giving up; only game with any problems so far on my new windows 10 install.  Worked fine with windows 7.  Don't really need any more reason to not play, but still wanted to for old-time's sake.

I think if there weren't so many other problems with the game I might try to talk to my uncle about the router, but really?  I don't see that it should be an issue.

Also strange is the need for Fallen Earth to be run as 'administrator'.

Got APB Reloaded to work though, no problem.  Re-installing via steam because Hawken and SuperMNC require steam and i wound up installing fallen earth with steam so figured might as well do APB with steam.  Curious to see if it requires administrator still.  I don't think so, the shield is missing from the icon, though it did ask me first time it ran for permission.

I would have to conclude after all the talk and issues and now this, that fallen earth is truly dead and just waiting to be buried.  R.I.P.


uninstalling, forever

1 user(s) are reading this topic

0 members, 1 guests, 0 anonymous users