Jump to content
Sakebee

10/24 Bug Reports

Recommended Posts

This is a thread for bugs related to the 10/24 open beta playtest.

 

When submitting bugs, we ask that you do your best to format them in the following way. This will give us the best chance of finding the issue you came across and making sure it gets fixed! Be sure to check out our known issues list and skim this thread before posting so we don't get a bunch of duplicate issues. Here is the structure we would prefer:

 

  • Summary: A short description of the bug – think of it as similar to a newspaper headline.
  • Game Version: This is important for tracking reasons. Including the version number lets us see how long a bug has been present within the game and where it was first spotted.
  • Description: A detailed description of the issue that you’ve found. Try to stay concise and clear in your information while being specific.
  • Steps to Reproduce: This part can be the most important part of a bug report. The steps that you took to reproduce this issue.
  • Reproduceability: If you find the reproduction of an issue, how many times are you able to reproduce it following these steps you wrote above? You can use a percentage or a fraction (ie. 2/5 or 5/5 times. 25% of the time or 100% of the time, for example).
  • Results: What’s actually happening when you follow these steps.
  • Expected Results: What should have happened instead of the bug.

 

Example - A bug report for a specific issue

 

 


Summary: Ammo resupply issue

Game Version: 1.19.5.789497

Description: Ammo is currently not being re-supplied to the end user during a mission under any circumstance. This happens for weapon changes, and for weapons equipped before missions

 

Steps to reproduce:
1. Launch the game.
2. Enter any district, and either change weapon, or shoot some bullets and attempt to resupply ammo
3. Notice that it does not do this.
 

How many times have you recreated this bug: 3/3

Expected results: This shouldn't be happening.
 

 

 

Thanks! We really appreciate everyone who takes the time to let us know about an issue they found.

Share this post


Link to post
Share on other sites
On 10/22/2020 at 2:03 PM, ShawLOL said:

And at the End: They won't fix it!

or just remove the problem all together

Edited by ReaperTheButcher

Share this post


Link to post
Share on other sites

Sorry if this is a bit early, but I encountered this while making sure I had the beta downloaded in advance. I didn't see this in the known issues list (outside of a mention of dual monitors and refresh rate).

 

 

Summary: Graphical glitched caused by VSync settings

Game Version: 2.1 Beta (I think. I tested this using the beta client on October 23rd)

Description: Graphical glitches/artifacts occur if VSync is on. This appears to especially effect the UI. These glitches happen regardless of if "Smooth Frame Rate" and/or "Support Variable Refresh Rate (Requires Windows 10)" are on or off. These glitches also seem to appear if "Support Variable Refresh Rate" is turned off. Things seem to go back to normal if the user turns VSync off at any point.

 

Steps to reproduce:
1. Launch the game.
2. Turn VSync on. Other graphics settings don't seem to matter (except for Support Variable Refresh Rate, which causes similar issues when turned off regardless of VSync).
3. Graphics artifacting (mainly with the UI) occurs until VSync is turned back off.
 

How many times have you recreated this bug: 3/3

Expected results: No graphical glitches.

 

Hardware information:

CPU: Intel i7-6700K (4.01 GHz)

RAM: 16 GB DDR4

GPU: RTX 2070 Super (Driver version 446.14)

Displays:

  • Primary: 1920x1080 (native) monitor with a 60 GHz refresh rate
  • Secondary: 1920x1200 (native) monitor with a 60 GHz refresh rate (Windows lists it as 59 GHz but Nvidia Control Panel and the monitor's built in menu say 60 GHz, for what it's worth)

Video of me recreating the bug:

 

The graphical glitches start off small but become much more severe after I change the graphical settings early on. I turn off VSync and start experimenting with other settings at 1:35.

Of course since the third open beta hasn't started yet, I've only been able to try this on the login screen.

 

Please let me know if you want me to test anything else or have other questions.

Share this post


Link to post
Share on other sites

Summary: The advanced graphics settings do not apply.

 

Game Version:

 

Description: If you change any advance graphics settings and restart the game, those settings are reset the next time you launch the game. Some settings require you to restart the game to apply them, which means you cannot change them. The settings are saved to the config file, APBMachineOptions.ini

 

Steps to Reproduce

  1. Open the options menu.
  2. Click Advanced
  3. Change some settings.
  4. Click OK.
  5. Restart APB.
  6. Open the options menu again.
  7. The settings are not applied.

 

Reproducibility: 3/3

 

Results: The advanced graphics options do not apply at startup.

 

Expected Results: The advanced graphics options should apply at startup.

Edited by SquirrelFace

Share this post


Link to post
Share on other sites

Is Beta up? cause im long-in in and says "Servers maybe down for maintance"

Edited by PoliceRuleGR

Share this post


Link to post
Share on other sites
30 minutes ago, PoliceRuleGR said:

Is Beta up? cause im long-in in and says "Servers maybe down for maintance"

same question. cant log in right now

Share this post


Link to post
Share on other sites
1 hour ago, PoliceRuleGR said:

Is Beta up? cause im long-in in and says "Servers maybe down for maintance"

 

1 hour ago, Shq said:

same question. cant log in right now

 

When is 9 AM UTC? ... Not for another 15 minutes

Share this post


Link to post
Share on other sites
Just now, WhackyWayne said:

when are servers coming up? its 15 minutes past, just curious

servers are up

Share this post


Link to post
Share on other sites
Just now, JellyBOY said:

error code 10007

are you still getting that now, can you recheck?

Share this post


Link to post
Share on other sites
8 minutes ago, ComFeyer said:

are you still getting that now, can you recheck?

Thank you

Share this post


Link to post
Share on other sites

Summary: Directional audio is broken for headphone users.

 

Game Version: 2.1

 

Description: Sounds drastically shift between left and right. Sounds coming from objects that are not directly in the center of my screen only play in 1 ear. While driving, my vehicle's audio constantly switches between left and right, but rarely plays in both.

 

I have tested this with 3 audio interfaces.

- Motherboard audio

- Schiit Modi Multibit

- Focusrite Scarlett Solo 3rd Gen

 

Steps to Reproduce:

  1. Launch APB and join a district
  2. Find a noise source, like gunshots or a vehicle driving.
  3. Place said noise source slightly off center from your screen.

 

Reproducibility: 100%

 

Results: The directional audio hard shifts between left and right.

 

Expected Results: The directional audio should play from the direction the sound is coming from. If someone is shooting 20 degrees right, you should hear most of the sound in your right ear, and some sound in the left.

Edited by SquirrelFace
  • Like 1

Share this post


Link to post
Share on other sites

Summary: Invisible barrier at the Fortuna Maria in Waterfront can be walked on.

 

Game Version: 2.1 Beta Oct 24th (2.1.834.943)

 

Description: The invisible barrier that stops players from jumping into the water on the West side of the Fortuna Maria can be walked on between the two gangplanks.

 

Steps to Reproduce: 

1) Climb the gangplank to this point:

LDXghQF.png

 

2) Jump over the railing. You should now be on top of an invisible barrier. It can be accessed from the other gangplank but it seems to be easier to do from the one nearest the stern of the ship.

 

Reproduceability: 100%

 

Results: Player character will be on top of an invisible barrier that extends all the way to other gangplank and will appear to be standing in mid-air. None of the other invisible barriers around the ship appear to be accessible in this manner.

 

Expected Results: Character should fall to ground, or be unable to jump over the gangplank railing.

Edited by MrChan

Share this post


Link to post
Share on other sites

Summary: Losing frames when moving mouse fast

 

Game Version: 2.1 Beta Oct 24th

 

Description: When you either turn fast or shake your mouse you lose almost all frames in financial. 

 

Steps to Reproduce: 

1) Move mouse fast.

 

Reproduce-ability: 100%

 

Results: Frames go from 80 to 14 for me.

 

Expected Results: Frames should be consistent

Share this post


Link to post
Share on other sites

Summary: Game crashes when accepting a clan invite

Game Version: 2.1.834.943

Description: When using the interraction key > and selecting a friend, I invite them to the clan. Once they accept the clan invite, their game crashes.

 

Steps to reproduce:
1. Group invite someone
2. Use interraction key to player > and select invite to clan
3. Player thats accept the clan invite gets a game crash upon pressing Y
 

How many times have you recreated this bug: 2/2 (2 different players)

Expected results: The player should join the clan and not crash. One player joined the clan, the other one didn't. But both crashed.

Edited by Infinito

Share this post


Link to post
Share on other sites

Summary: Random crash when loading Abbigton Towers

Game Version: 2.1.834.943

Description: Spent about an hour in missions districts to benchmark, tried to get into FC, game crashed.

Quote

14:03:36 - Log: Wake up APB_Catcher.
14:03:36 - Log: Wait for APB_Catcher to finish.
14:03:36 - Log: APB_Catcher failed!
14:03:36 - Log: Creating external mini-dump failed!
14:03:36 - Log: Exception: Sending CrashReport callback event...
14:03:36 - Log: Client crash report
14:03:36 - Log: Map AsylumDistrict_MASTER
14:03:36 - Log: PlayerController object not found.
14:03:36 - Log: Exception: Calling HandleError()...
14:03:36 - Log: === Critical error: ===
Fatal error!


 

Steps to reproduce:
Join FC towers
 

Haven't yet

Expected results: Join FC

Edited 4 minutes ago by Infinito

Share this post


Link to post
Share on other sites

Summary: Weird view behavior when jumping in a big vehicle (bank truck / ambulance) from the passenger side

Game Version: 2.1.834.943

Description: When entering an ambulance or bank truck from the passenger side, the vehicle view dissappears temporary until you're in the car.


Steps to reproduce:
1. Find an ambulance/Bank truck
2. Enter from passenger side
 
How many times have you recreated this bug: 3/3

 

 ----------- --------------- --------------- --------------- -------------------

 

Summary: Honk sound sounds like the vehicle is behind you

Game Version: 2.1.834.943

Description: When honking in a vehicle, the sound sounds like it's from behind you.

Steps to reproduce:
1. Enter a vehicle
2. Press the honk button.

How many times have you recreated this bug: 3/3

Edited by Infinito

Share this post


Link to post
Share on other sites

Summary: Missing audio when mugging

Game Version: 2.1.834.943

Description: When mugging pedestrians, there is no punching audio when your character hits the pedestrian. You can only hear the pedestrian's voice.

Steps to reproduce:
1. Enter an action district as a criminal.
2. Attempt to mug any pedestrian.

3. Listen for the punching audio.

 

Reproduceability: This bug happened with 100% of the pedestrians. I restarted the game 2 times.

 

Results: No sound of the pedestrian being hit, only his voice.

Expected results: Each time your character hits a pedestrian, a sound of him being punched should play.

Share this post


Link to post
Share on other sites

Summary: Input delay in "fullscreen" mode 

Game Version: 2.1.834.943

Description:  When you fire a gun, when you snap with your mouse (turn really fast and shoot) there is a pretty good delay on the shot. 


Steps to reproduce:

1. Fire any gun and try to snap also. 

 

Reproduceability: 100%

 

Results: Really weird feeling and pretty hard to get a good firing delay going with semi-auto weapons

Expected results: No input delay, needs to be snappy. 

 

Specs:  

i7-8750h 
GTX 1060 6GB
32 GM DDR4 2666 mhz

Graphics Settings : Tried on Minimal, Medium and Ultra 

Resolution used : 1280x960 144hz AND 2560 x 1440 144hz 

OS Version : Windows 10 64Bit / Build 18362.1139 

NVIDIA Driver :  456.71 

Edited by Kalder

Share this post


Link to post
Share on other sites

Summary: In-game display settings not working.

Game Version: 2.1.834.943

Description:  Can't change or modify any display settings, sliders wont move, making it stuck on 1280x720 resolution, ingame caps 100fps even tho my screen is 144hz by default. Changing .ini files didnt work either, since the game keeps overwriting them. 

 

 

Specs:  

i7-10750h
GTX 2060
16GB RAM

Laptop display 144hz full hd.

OS Version : Windows 10 64Bit

Share this post


Link to post
Share on other sites

Summary: Cannot rename outfits

Game Version: 2.1.834.943

Description: Attempting to rename an outfit results in a warning stating the name is not suitable.


Steps to reproduce:
1. Attempt to rename an outfit in the clothing editor

2. It pops up the warning as if the name does not meet criteria
 

How many times have you recreated this bug: 3/3

Expected results: The name should work.

Share this post


Link to post
Share on other sites

Summary: 18 OCA's, 2 N-TEC's and 5 Stabba CCG's in my inventory

Game Version: 2.1.834.943

Description: There are 18 0CA 626'es, 2 N-TEC's, and 5 Stabba CCG's, all 0 slot in my weapons list. I'm guessing it has to do with migration, since I can equip them all just fine.

Just see for yourself (Vending machine ammo UI) :
unknown.pngunknown.pngunknown.png


IMPORTANT EDIT : I've managed to give myself more N-TEC's by accidentally completing the Basics tutorial multiple times. I got the reward email twice, and selecting the same weapon twice gave me two 0-slot N-TEC's in my inventory, listed exactly like the other weapons. It's potentially something to investigate in relation to this.


Steps to reproduce:
1. Go to a vending machine and select ammo type
2. Check list of weapons
3. Alternatively, open your inventory and select a weapon, they will show up there

How many times have you recreated this bug: 3/3 logins since beginning of this beta, guns remained

Expected results: I shouldn't have any of these extra weapons.
_______________________________________________________________

 

 

Summary: Character shading looks odd in Character Info window

Game Version: 2.1.834.943

Description: The character thumbnail in Character Info looks strange. Although the skin is fine, hair looks way too bright and casts no shadows on the face.
 

In addition, you can see in this screenshot, on the pants, that there's a weird dithering effect going on between black and grey.
unknown.png

I've seen someone experiencing this describing it as "DOOM-like colors" for their character.

Steps to reproduce:
1. Join any district
2. Press J when spawned in
3. Observe the 3d character model

How many times have you recreated this bug: 3/3 on all districts

Expected results: The character should have equal lighting and shading on all parts.

Edited by Catgorl

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.

  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...